🗝
summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..7f5317e
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "dissociate"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+argon2 = "0.5.3"
+axum = { version = "0.7.4", features = ["macros"] }
+axum-extra = { version = "0.9.2", features = ["cookie"] }
+bincode = "2.0.0-rc.3"
+cursive = { version = "0.20.0", default-features = false, features = [
+    "crossterm-backend",
+] }
+eyre = "0.6.12"
+maud = "0.26.0"
+nanoid = "0.4.0"
+ouroboros = "0.18.3"
+oxide-auth = "0.5.4"
+oxide-auth-axum = "0.4.0"
+paste = "1.0.14"
+rand = "0.8.5"
+serde = { version = "1.0.197", features = ["derive"] }
+serde_json = "1.0.114"
+tap = "1.0.1"
+tokio = { version = "1.36.0", features = ["rt-multi-thread", "macros", "fs"] }
+toml = "0.8.10"