🗝
about summary refs log tree commit diff
path: root/PKGBUILD
diff options
context:
space:
mode:
authormia <mia@mia.jetzt>2024-04-24 22:44:53 -0700
committermia <mia@mia.jetzt>2024-04-24 22:44:53 -0700
commit7a7bb361396e03707f1f12b10fb61f5d31d91280 (patch)
tree260b69dfa6d5d94810b4c833728e578a9e6a58c3 /PKGBUILD
downloadzoner-7a7bb361396e03707f1f12b10fb61f5d31d91280.tar.gz
zoner-7a7bb361396e03707f1f12b10fb61f5d31d91280.zip
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..880f455
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=zoner
+pkgver=1
+pkgrel=1
+arch=(any)
+makedepends=(python-build python-installer python-wheel)
+depends=(python-requests)
+source=(pyproject.toml zoner.py)
+sha256sums=(SKIP SKIP)
+license=(MIT)
+
+build() {
+    python -m build --wheel --no-isolation
+}
+
+package() {
+    python -m installer --destdir="$pkgdir" "$srcdir"/dist/*.whl
+}