🗝
about summary refs log tree commit diff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..880f455
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=zoner
+pkgver=1
+pkgrel=1
+arch=(any)
+makedepends=(python-build python-installer python-wheel)
+depends=(python-requests)
+source=(pyproject.toml zoner.py)
+sha256sums=(SKIP SKIP)
+license=(MIT)
+
+build() {
+    python -m build --wheel --no-isolation
+}
+
+package() {
+    python -m installer --destdir="$pkgdir" "$srcdir"/dist/*.whl
+}